ionic 5 안드로이드 No installed build tools found 해결


▶ 에러 메시지

ionic No installed build tools found. Install the Android build tools version 19.1.0 or higher.

아이오닉5 안드로이드 사용 시 발생하는 오류입니다.

원인 및 해결 방법부터 말씀드리면, 환경변수 ANDROID_HOME 은 더이상 사용하지 않으며 ANDROID_SDK_ROOT 를 사용해야 합니다. ANDROID_HOME만 설정했다면 무조건 발생하는 오류입니다.


일단, 에러 메시지의 뜻은 Gradle 동기화 실패 오류입니다. 설치된 빌드 툴이 없으니 안드로이드 빌드 툴 19.1.0 또는 그 이상을 설치하라는 에러 메시지입니다.


제 경우엔 변경된 "환경 변수" 설정을 누락한 게 원인이었습니다. 추가로 안드로이드, Gradle, IONIC, 비주얼스튜디오코드 등이 업데이트되면서 좀 꼬인 케이스가 되겠습니다.


해결 방법은 쉽습니다.

▶ 안드로이드 스튜디오

환경변수 : https://developer.android.com/studio/command-line/variables

위 안드로이드 사용자 가이드를 참고한 뒤 OS에 맞춰 환경변수만 맞춰주면 됩니다.


Windows


setx ANDROID_SDK_ROOT "C:\android-sdk-windows"
setx PATH "%PATH%;%ANDROID_SDK_ROOT%\tools;%ANDROID_SDK_ROOT%\platform-tools"


맥 OS X


export ANDROID_SDK_ROOT=/<installation location>/android-sdk-macosx
export PATH=${PATH}:$ANDROID_SDK_ROOT/tools:$ANDROID_SDK_ROOT/platform-tools


리눅스


export ANDROID_SDK_ROOT=/<installation location>/android-sdk-linux
export PATH=${PATH}:$ANDROID_SDK_ROOT/tools:$ANDROID_SDK_ROOT/platform-tools



다시 말씀드리지만 ANDROID_HOME 환경변수는 사용하지 않습니다. ANDROID_SDK_ROOT로 대체되었습니다.


또한, 안드로이드 스튜디오를 사용하는 분들이라면 ionic 5 안드로이드 No installed build tools found 해결 방법이 조금 다른데요. Project Structure - android - Build Tools Version 에서 알맞은 버전을 선택하세요. 위 글은 IONIC5 기준입니다.




댓글(0)

Designed by JB FACTORY