파이썬 패키지 호환성 확인 사이트

파이썬 패키지 호환성 확인 사이트



파이썬 3.0으로 넘어오면서 대대적인 변화가 일어났습니다. 그래서, 파이썬 2.5나 2.6과 호환이 잘 되던 패키지들에 문제가 생기기 시작했죠.


요즘엔 패키지 대부분이 3.0을 지원하나 아직까진 미흡한 것들도 존재합니다. 2.5나 2.6으로 구현된 시스템이 너무 많기에 호환성 사이트에서 확인할 일이 종종 생깁니다.


녹색은 3.0 (또는 그 이상)을 지원하고, 빨간색은 지원하지 못합니다.

작업 중 뭔가가 잘 안 되면 이 사이트를 방문해 확인하세요.


아래처럼 녹색으로 표시된 패키지는 파이썬 3.0에서 호환이 되는 겁니다.


Python 3 Wall of superpowers파이썬 패키지 호환성 확인 - Python 3 Wall of superpowers


근데, 아래처럼 빨간색으로 표시된다면 사용할 수 없다는 뜻이죠.


파이썬 패키지 호환성 확인 - 빨간색은 3에서 사용 못함파이썬 패키지 호환성 확인 - 빨간색은 3에서 사용 못함


MySQL-python과 carbon이란 패키지는 파이썬 3.x에서 사용을 못 하는 겁니다.


간단하게 확인이 되네요.


파이썬 패키지 호환성 확인 사이트

댓글(0)

Designed by JB FACTORY