닷넷프레임워크 하위 호환성 (.net framework 상위 최신 버전 설치)

닷넷프레임워크 하위 호환성 (.net framework 상위 최신 버전 설치) 




  • Microsoft .NET Framework 1.1
  • Microsoft .NET Framework 2.0 SP2
  • Microsoft .NET Framework 3.0 SP2
  • Microsoft .NET Framework 3.5 SP1
  • Microsoft .NET Framework 4 Client Profile
  • Microsoft .NET Framework 4 Extended


가령, 위와 같은 닷넷프레임워크가 버전별로 설치가 되어 있으면, 4버전 이외의 하위 버전은 모두 삭제해도 상관이 없느냐가 문제입니다.


일반적으로 원글을 적으신 분이 추천하는 닷넷프레임워크 설치 버전은 아래와 같습니다.



  • NET Framework 2.0 SP2
  • NET Framework 3.0 SP2
  • NET Framework 3.5 SP1
  • NET Framework 4



.net framework 호환성[닷넷프레임워크 하위 호환성 (.net framework 상위 최신 버전 설치)]



닷넷프레임워크의 단점은,


특정 버전으로 제작된 프로그램의 경우 다른 버전으로 동작하지 않는다는 점입니다.


말도 많고 탈도 많았던 1.X 버전은 이제 거의 사용하지 않기 때문에, 현재로써는 2.X, 3.X, 4를 설치하는 것을 추천합니다.


.NET Framework 2.0 SP2와 3.0 SP2가 설치되어 있지 않다면, .NET Framework 3.5 SP1을 사용하지 못합니다.


그래서, 3.5 SP1이 설치된 경우 2.0 SP2이나 3.0 SP2를 제거한다면 문제가 발생할 가능성도 커집니다.


추가로, .NET Framework 1.0과 1.1, 그리고 2.0이 설치되었다면, 2.0을 사용하기 때문에 1.X 버전은 삭제해도 무방합니다.




마지막으로, [프로그램] 닷넷프레임워크의 버전 특성과 설치할 버전(.NET Framework)라는 포스팅도 참조하시면, 많은 도움이 될 것이며, 2012년도에 4.5가 나오면서 위와 같이 고생할 필요는 많이 줄었습니다.


2019년 현재 거의 호환이 됩니다.


 닷넷프레임워크 하위 호환성 (.net framework 상위 최신 버전 설치)

written by vicddory

댓글(0)

Designed by JB FACTORY