우분투 apt-get update install 에러 (Failed to fetch, Ubuntu 업데이트)

우분투 apt-get update install 에러 (Failed to fetch, Ubuntu 업데이트)


출처 - ubuntu LTS 14.04 (32bit) (깨짐)


출처는 스택 오버플로우였는데 링크가 깨졌네요. 드문 경우인듯...


아무튼,


1
sudo apt-get update
cs


우분투에서 sudo apt-get update하면 아래처럼 에러가 뜹니다.


에러 메세지


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
Ign file: binary// InRelease
Ign file: binary// Release.gpg
Ign file: binary// Release
Err http://ports. ubuntu.com precise InRelease
 
Err http://ports. ubuntu.com precise-update InRelease
 
Err http://ports. ubuntu.com precise-security InRelease
 
Err http://ports. ubuntu.com precise Release.gpg
  Temporary failure resolving 'ports.ubuntu.com'
Err http://ports. ubuntu.com precise-updates Release.gpg
  Temporary failure resolving 'ports.ubuntu.com'
Err http://ports. ubuntu.com precise-security Release.gpg
  Temporary failure resolving 'ports.ubuntu.com'
Ign file: binary/ Translation-en
Reading package lists... Done
 
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/precise/InRelease
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/precise-updates/
W: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/dists/precise-security/
cs

우분투 터미널에서 확인하면 Err 메시지가 확인됩니다.


sudo apt-get update[Ubuntu failed to fetch] sudo apt-get update


이럴 땐, 우분투 터미널에서 아래 명령어를 넣어보세요.


1
sudo rm -rf /var/lib/apt/lists/* -vf
cs


깔끔하게 apt(Advanced Packaging Tool)를 정리[Ubuntu apt-get update] 깔끔하게 apt(Advanced Packaging Tool)를 정리


깔끔하게 우분투에서 apt(Advanced Packaging Tool)를 정리하고 다시 update.


apt 정리하고 다시 update 1[Ubuntu failed to fetch] apt 정리하고 다시 update 1


apt 정리하고 다시 update 2[Ubuntu apt-get update] apt 정리하고 다시 update 2

정상적으로 우분투 패키지 정리가 완료되었으니 이젠 upgrade


apt-get upgrade[Ubuntu failed to fetch] apt-get upgrade


additional disk spack will be used[Ubuntu apt-get update] additional disk spack will be used


우분투 터미널에 원하던 글이 드디어 뜹니다.


당연히 y를 누르고 엔터.


update로 리눅스 패키지 갱신[Ubuntu failed to fetch] update로 리눅스 패키지 갱신


진행되다보면 아래 그림처럼 패키지 설치에 대한 메시지가 뜨는데 그냥 엔터를 누르세요.


Configuring libc6 - yes - 1[Ubuntu apt-get update] Configuring libc6 - yes - 1


Configuring libc6 - yes - 2[Ubuntu failed to fetch] Configuring libc6 - yes - 2


이렇게 하면 끝.


우분투 apt-get update install 에러 (Failed to fetch, Ubuntu 업데이트)

댓글(0)

Designed by JB FACTORY